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2. Foreword – Infoportal and Support 
Gentics Contetn.Node is an enterprise Content Management System product which 
allows you to create, edit und publish contents of your webpage. This document 
serves to support your common work with Gentics Content.Node. It is intended to 
introduce you to the basic functions of Gentics Content.Node. If you need more 
detailed information please visit the Gentics Infoportal www.gentics.com/infoportal. It 
is available to all Gentics customers and represents a platform for the exchange of 
information. In this Infoportal you will find articles on frequently asked questions 
(FAQ) to help you expand your knowledge of Gentics products and you can contact 
our Gentics help desk via this platform. 

3. First steps 
The following chapter gives a brief overview of your first steps using Gentics 
Content.Node. 

3.1  Login and logout 
Enter your login and password at the login mask. If you do not have a login yet, 
please contact your administrator. 

 
Image 1 - Login to Gentics Content.Node application server 

Note: You have to allow pop-ups for Gentics Content.Node in your web browser 
otherwise you can’t login. 

 
Image 2 – Stream: right corner 



 

© Gentics Software GmbH 

Enterprise Portals and Content Management Systems 
www.gentics.com 

Page 7 
 

  

 

The logout button is located at the top right corner of your browser window. 

Note: Always log out correctly using the logout button. Do not simply close the 
window! Other persons with access to your workstation could continue to work within 
a certain time under your login in Gentics Content.Node.  

 

3.2  Password change 
Your login as well as the button to edit your user profile is displayed above the log out 
button (refer to Image 2). Clicking on “Edit profile” allows you to change your 
password. Enter a new (identical) password twice to change your password. 

3.3  User rights 
Your user rights are automatically linked to your login. These are assigned by the 
system administrator and define the possible work steps that you are allowed to carry 
out in the system. The display of elements in the navigation tree and in the menu is 
also linked to the user rights. User rights can be changed by the system administrator 
at any time. 

3.4  Start page 
As soon as you log in to the system, important information will be listed in the content 
section (refer to Image 3). 

The left-hand column indicates whether you have received new messages via the 
internal messaging system and which users are currently logged in to the system as 
well as the quickjump (For detailed information about the quickjump, please read 
section 4.2 “Navigation” page 9). 

The last five pages edited by you and their status are displayed in the right-hand 
column. Below, you will find the folders that you have visited last and administrative 
information like the Gentics Content.Node version you are using, how many pages are 
waiting for publication and how long this will take approximately. 
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Image 3 – Start page 
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4. Interface 
The Gentics Content.Node interface is simply and clearly arranged and is oriented to 
existing industry standards. 

The user interface consists of the following sections: 

1. Stream section 2. Navigation 3. Menu bar 

4. Assistant area 5. Content area  

 
Image 4 - Gentics Content.Node interface 

4.1  Stream and status line 
The stream is an image mask in the upper section of Gentics Content.Node that can 
be adapted individually under [Settings] in the navigation section. In the foreground 
you’ll find the status line elements which contain information such as the number of 
new messages in your inbox as well as the current date and time and the number of 
users currently logged in. 

 
Image 5 – Stream: left corner 

4.2  Navigation 
In the left column, the navigation section for the CMS is allowing you (depending on 
your permissions) to access various Gentics Content.Node functionalities, the 
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individual projects, the whole folder structure within the individual projects in the form 
of a "tree structure", as well as [Settings] for your login, [Inbox] for sending and 
receiving messages and the [Queue] a list of all the pages waiting for publication, if 
such a workflow is defined and you got rights to see it. 

 
Image 6 - Navigation and folder structure 

Note: Clicking on  or pressing crtl+q opens the quickjump. After filling in a page ID 
or part of a page title you can jump easily to this page without clicking at any folder in 
the tree navigation. Clicking on  collapses the tree in the navigation section. 
Clicking on  minimizes the whole navigation section, if you got a small display like 
on some laptops and need a larger content area.  

4.3  Menu bar 
The menu bar allows you to call up the individual functions for the active point in the 
navigation section. The menu adapts itself to the current situation depending on your 
user rights and displays the all actions available for you. 

 
Image 7 – Menu bar 

4.4  Assistant area 
To the right of the navigation section you can switch between different views (pages, 
images, files or folders) and you will find an additional list of menu items most 
frequently used in the respective view as well as your history of used folders, pages 
etc. 
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If you need a larger content area, you can minimize the assistant area through 
clicking on . 

 
Image 8 – Assistant area 

4.5  Content area 
The content area is the central working area in Gentics Content.Node. It displays all 
the objects which you can select via the navigation section. You can find information 
about your current position in the folder structure at the breadcrumb menu in top-left 
at the content area and different actions and functions, depending on your current 
view in the action menu. 

 
Image 9 – Content Area with [View > Pages] view 

At the content area you will edit or preview pages, upload images etc. 
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Image 10 – Content area with [Page > Preview] 
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5. Working with Gentics Content.Node 
All objects in Gentics Content.Node are displayed in lists. If you select a folder in the 
navigation section, a list of pages contained in this folder is displayed in the content 
area. All listed contents can be sorted, according to the respective column, by clicking 
on the column header (e.g. name, last edited, etc.). In the list view, you can quickly 
and easily carry out [Actions] on one or more objects in the list. It depends on your 
[View] (e.g. [View < Pages] or [View > Images]) which action you can carry out. 

There are two possibilities for applying an action to an object: 

• Right-click on the name of an object and the context menu will be displayed. 

 
Image 11 - Context menu via right-clicking on objects 
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• Mark one or several objects via selecting their checkbox in the left column (the 
background of the selected objects turn blue) and select an action from the action 
dropdown menu. 

 
Image 12 - Carrying out actions on objects via the action dropdown menu 

5.1  Working with folders 

In Gentics Content.Node are two types of folders: Nodes (=projects ) and folders (

) for content like pages, images etc. Nodes are created by the administrator and 
represent the highest hierarchical level within a project and are clearly recognizable 
with a project name. Folders serve for clear management of objects and often are 
used as a basis for the website navigation structure. 
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5.1.1 Folder structure and view 

Each folder can have an arbitrary number of sub-folders. Clicking on the symbol in 
front of the folder name in the navigation section opens the tree structure with the 
subordinate folders (refer to Image 13). If the contents of a folder are to be 
displayed, click on the folder name. The folders, pages, etc. managed in this folder are 
displayed in the content section. 

 
Image 13 – Folder structure 

In order to call up the correct view select [View -> Folders], [View -> Pages], etc at 
the menu bar (refer to Image 14) or at the assistant area. 

 
Image 14 - View 

Note: The structure in Gentics Content.Node does not necessarily have to correspond 
exactly to the structure on the website. You can, for example, create an “archive” 
folder in Gentics Content.Node in which outdated pages are stored, even if the 
website does not contain a menu item "Archive" and the archived pages are no longer 
published. 

Note: Attention must be paid to logical consistency and clarity when creating and 
naming folders. A good structure is the best way to avoid confusion. 
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5.1.2 Create a folder 
In order to create a new folder select the node or folder in the navigation section in 
which you want to create a new folder. The menu contains the command [New -> 
Folder] with which a new folder is created (refer to Image 15). 

 
Image 15 – Menu bar: New folder 

As soon as you select [New -> Folder] in the menu bar, a dialog window opens in the 
content section (refer to Image 16). 

(1) You can enter the name of the new folder. 

(2) You can define the name of the directory under which all objects contained in a 
folder are stored on the web server which has effect to the URL of the containing 
pages, images etc. For example: http://www.gentics.com/Content.Node/directory/ 

If you do not wish to specify a directory of your own, simply leave this field blank. 
Then all pages stored in this and maybe folder(s) are published in the same directory 
e.g. http://www.gentics.com/Content.Node/ 

Note: Within a directory on the web server, file names for pages and images (e.g. 
"news.html" or "logo.gif") most only be used once! 

(3) You can enter the information that is to be displayed in the assistant area when 
you move the mouse over the respective folder name under [View -> Folder] (refer to 
Image 17). 
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Image 16 – New folder dialog 

Clicking on [OK] confirms your input and you return to the list view. The new folder 
can be selected in the navigation section. 

 

 
Image 17 
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5.1.3 Move a folder 
In order to move one folder to another click on the higher ranked folder, if necessary 
change the view [View -> Folder], mark the folder to be moved by selecting the 
checkbox and then select [Move] via the action menu (refer to Image 18) or the 
context menu via right-click on the folder.  

  
Image 18 – Action menu 

To confirm the action click on specified target folder (refer to Image 19). 

 
Image 19 – Select target folder 

Note: If you wish to move several folders at the same time, the selected folders can 
only be moved to the same target folder, not to different folders. 
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When moving folders all links are automatically moved at the same time. This saves 
you having to link pages, files and images again if the publication directory of the 
folder should have changed. 

5.1.4 Rename a folder 
Select the desired folder and click on [Folder -> Properties] at the menu bar or right-
click on the folder’s name at the navigation tree and select [Properties] and the folder 
properties dialog appears. At the dialog window you can edit (1) name of the folder, 
(2) the directory and (3) the description of the selected folder (refer to Image 20). 

 
Image 20 – Folder properties  

 
Image 21 – Right-click menu 
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5.1.5 Delete a folder 
To delete a folder, you have to select the higher-ranking folder or node in the 
hierarchy and change to [View -> Folder]. Mark the checkboxes of all the folders you 
want to delete and select [Delete] via the action menu or the delete-symbol next to it 
(refer to Image 22). Individual folders can also be deleted by right-clicking on the 
folder name. 

 
Image 22 - Delete folders 

Note: All objects such as pages, images, files that are contained in the folder or 
subfolders including their content are lost when a folder is deleted. Although the link 
management of Gentics Content.Node prevents invalid links occurring on the page by 
deactivating these links, you should nevertheless take care not to inadvertently delete 
objects linked from other pages. 

 

5.2  Working with Pages 
Pages generally provide contents for websites and are always based on a template 
providing you with editable parts to enter content into the page. Page statuses 

Every page has a status which is important for editing and publishing. You can identify 
the status of a page based on its icon in the list view. Following page states are 
possible: 

 The page is published. 

 
The page is stored, but not published. This page version is maybe different to 
the published page version. Everybody can edit or publish this page. 

 
The Page is locked for editing. This page is locked, has not been saved and 
currently cannot be edited by another user. 

 The Page is waiting in queue to be reviewed by an editor with publishing 
permissions. 
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5.2.1 Create a page 
Select the folder in which you want to create a new page and select [New -> Page] at 
the menu bar and a dialog window will be displayed (refer to Image 23): 

 
Image 23 – New page 

(1) Enter a name for your page in the field [Name]. The page name is often used as 
page header (This might be different in your specific website project, since it depends 
on the project’s implementation). 
(2) You can enter a [Description] of the page using key words or full sentences. 
(3) A [Priority] can then be assigned if the page is to be sorted by priorities (e.g. in 
overviews). Whether or not you should use the field [Priority] is determined by your 
administrator. 
(4) The filename will be created automatically based on the page name while clicking 
[OK]. If you assign the file name yourself, you must ensure that the correct file 
extension is used and that no special characters, accents or blanks are employed. You 
can omit the extension (e.g. .html); the system then adds this extension 
automatically. 
(5) You can choose a template for your page. The number of available templates 
depends on the implementation of your website  

Note: The choice of the template is particularly important. The templates available in 
this folder are displayed in a drop-down field. When you select the template, you 
define the appearance and function of the new page. 

After confirming your inputs via clicking [OK] the page will be opened in editing mode. 
In section “ 
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Edit content with Aloha Editor” (page 29), we explain how you continue editing a 
new page. 

5.2.2 Move a page 
When you are in [View -> Pages], select the checkboxes of the pages you want to 
move and select [Move] in the action menu. The move dialog will be displayed and 
you confirm the target folder by clicking on it. 

Note: If you want to move several pages at the same time by activating the 
checkboxes, you can only select one target folder for all the pages.  

When pages are moved, all links are automatically updated by the system. 

 
Image 24 – Move dialog 

5.2.3 Rename a page 
If you are in the edit mode of a page [Page -> Edit] you can rename the page via the 
menu bar [Page ->Properties]. The same dialog appears when creating a new page. 
All the relevant changes can now be made (refer to Image 23 – New page). 

5.2.4 Copying of pages 
If you are listing pages of a folder [View -> Pages], mark the checkboxes of the pages 
to be copied and select [Copy (Current folder)] or [Copy (Other folder)] in the action 
menu.  

If [Copy (Current folder)] is selected, the copy will be created in the same folder, 
[Copy (Other folder)] requires the selection of the desired folder to which the copy will 
be created. 
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For individual pages this action is also available via the context menu with the right 
mouse key. 

5.2.5 Delete a page 
Select the pages to be deleted in the list view [View -> Pages] by selecting the 
respective checkboxes. Use the action menu or the context menu by right-clicking and 
selecting [Delete in this language]. Additionally it is possible to delete all language 
versions of the page with [Delete in all languages]. 

Note: As soon as you confirm the delete action, it cannot be reversed! Please also 
note the following: If you delete a page, the respective links to this page on all other 
pages linked to this page will be automatically deactivated via the automatic link 
management routine. 

5.2.6 Saving a page 
Select [Page -> Save] in the menu bar in preview or edit mode. Saving a page means 
that all changes are saved, but the page is not published to the web server. This 
means that the last published version of the page is still visible to the visitors to your 
website. For this reason you should use [Page -> Save] particularly when you or 
another user wishes to edit/review the page again before it is placed "online" by 
publishing. 

5.2.7 Preview a page 
If you click on a page’s name in the list view or you click [Page > Preview] you open a 
page in the preview mode. This means, that you see the current version of the page 
without any node tag icons (for further information read section 6.2 Content 
elements, page 36), comments or other things which will not be published and visible 
at the frontend. 

5.2.8 Live Preview 
The live preview [Page > Live Preview] opens the selected page in another tab or 
window without any the stream, navigation and assistant area of Gentics 
Content.Node and it looks in the same way as a published page at the frontend. 

5.2.9 Publishing a page 
The publication of pages means that the page on your web server is made accessible 
to all visitors to your website. During the course of the publication, all pages linked to 
the newly published page are also updated. In the event of changes to a page listed 
on an overview, the page and the overview page will be published. Pages that are 
linked by links are also published in the same way. With each publication run (e.g. 
every 15 minutes), Gentics Content.Node transfers all pages published by you or 
other users since the last publication to the web server. 

In order to publish a particular page click - as long as you are in the page edit mode - 
in the menu bar or assistant section on [Page -> Publish]. This step can also be 
performed at the same time for several or all pages in a folder by activating the check 
boxes for those pages via the action menu in [View -> Pages]. Individual pages can 
also be published via the context menu with the right mouse key. 
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5.2.10 Queues/chief editor 
A workflow is a process by means of which pages have to be submitted to one or 
various higher-ranking users or administrators for release before the final publication. 
Only when the page has passed through the full release workflow is it published on 
the web server. Workflows are defined by the administrator on the basis of user rights 
and folder properties. If, for example, a chief editor of an online medium or a head of 
department in a company has to approve changes made by employees before 
publication, he will be notified when a new page is ready for release by means of a 
system message or via the "queue". 

 

5.3  Working with files and images 

5.3.1 Working with images 
Every file with the extension .jpg, .gif, .png and .bmp is recognized by Gentics 
Content.Node as an image. Other image formats, such as e.g. .tiff, .psd or .eps. are 
not displayed by any web browser - that is why they are handled by Gentics 
Content.Node as "File".  

5.3.1.1 Upload an image 
In order to use an image in Gentics Content.Node you have to upload one. Open the 
desired folder at the navigation and click [New > Image] at the menu bar. 

 
Image 25 – Upload new image 

Now a dialog will be displayed and you can choose a file on your hard drive for 
uploading at field [File] (1) (refer to Image 26). (2) You must enter a file name for 
your image. Always enter the correct file format like .jpg or .gif, otherwise the image 
will not work correctly. (3) You can choose an image size. There are some sizes given 
or you can enter a number of pixels or percent of the original size of the image. (4) 
You can enter an image description. Confirm your input via clicking [OK] and you will 
return to the list presentation of your selected folder’s content. 
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Image 26 – New image dialog 

Note: You can upload an image as well at the dialog of the image node tag. For 
further information please read section 6.2.1 Insert an image page, page 37. 

 

In order du upload several images us the multi-file upload for files (section 5.3.2.1 
“Upload a file”, page 26). 

 

 
Image 27 – List presentation 

If you click on [Preview] your chosen image will be open in another tab or window to 
preview it. In order to start the Gentics Content.Node Imagemanipulator, click on the 
name of the desired image. 

5.3.1.2 Image properties 
You can change the image name or the description of the properties via the Gentics 
Content.Node Imagemanipulator. In order to edit all properties, you have to open the 
image with the Gentics Content.Node Imagemanipulator and click [Image > 
Properties] and the properties dialog will be displayed. 
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(1) In order to update an image, you can open the properties dialog and select 
another image from your hard disc. This will replace the previous image version in all 
the places in your project where the picture has been used. (2) Enter a new name for 
the selected image. (3) Edit the description of the selected image. 

 
Image 28 – Image properties 

Note: After replacing an image, the previous version of the image will get. 

5.3.1.3 Move an image 
In order to move one or several images to another folder, mark the images and select 
[Move] via the action menu. In case of moving several images at one time you can 
only choose one destination. 

5.3.1.4 Delete an image 
In order to delete one or several images, mark the images and select [Delete] via the 
action menu. 

Note: After deleting an image it will be lost and will a not be displayed in any page 
even if an image tag refers to the deleted image. 

5.3.2 Working with other files 
All files not recognized as images are handled as files in Gentics Content.Node. 
Examples are files with the extension .docx, .xlsx, .pdf, or .zip, but also image files 
that cannot be displayed by a browser, such as .tiff or .eps. 

Files can be displayed in a separate list view with [View -> Files]. 

5.3.2.1 Upload a file 
In order to upload a new file, click on [New > File] at the menu bar and a dialog will 
be displayed. 
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Image 29 – New file 

Now click on [Upload files] and choose one or several files to upload. After confirming 
the finished upload via clicking on [OK] you will return to your previous view. 

5.3.2.2 Edit a file 
If you click on a file name, you have the opportunity to overwrite an existing file or 
change the file name or description in the file properties dialog. This essentially 
follows the same logic as for the images: If you wish to change a file centrally, it is 
advisable to overwrite the file. In this case the previous version of the file is lost. 

 
Image 30 – File properties 

(1) In order to change a file without uploading a new one, you can select another file 
which replaces the old one without editing all sites where the file is integrated. In this 
case the previous version is lost. (2) Enter a new name for the selected file. (3) Edit 
the description of the selected file. 
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5.3.2.3 Move a file 
In order to move one or several files from one to another folder, mark the files and 
select [Move] via the action menu. In case of moving several files at one time you can 
only choose one target folder. 

5.3.2.4 Delete a files 
In order to delete one or several files, mark the files and select [Delete] via the action 
menu. 

Note: After deleting a file it will be lost and will a not be displayed in any page even if 
an tag refers to the deleted file. 
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6. Edit content with Aloha Editor 
Aloha Editor is an HTML5 based "what you see is what you get"- editor (short 
"WYSIWYG"). This means with the Aloha Editor, you work directly in the page and not 
in a form-based pop-up window. You therefore see the text during editing almost 
exactly in the same way as the published page looks on the frontend or in the live 
preview mode. 

Aloha editor does not require browser specifications. It is compatible across multiple 
browsers and operating systems. 

6.1  Edit content 
After creating a page or clicking on [Page > Edit] the page gets opened in the editing 
mode and yellow rectangles highlight the editable areas (refer to Image 42). When 
you click into one of the yellow areas the floating menu from Aloha Editor will be 
displayed right above the cursor and the rectangle turns into blue (refer to Image 31). 
You can move the Aloha Editor to other areas on your screen while clicking into the 

grey area at the top and the cursor turns into this. Do not release the mouse key 
and move the cursor to the right position. You can fix the Aloha Editor at the new 
position through clicking on the pin at the top right corner. 

 
Image 31 – Aloha Editor 

Now you can enter all your content or copy it straight out of a text editor (e.g. 
Microsoft Word). Aloha Editor will recognize formatting like bold or italic, headlines, 
lists, tables etc. But you can format or reformat you content with Aloha Editor as well. 
Just mark the text and choose one of the given formatting like [Paragraph] for normal 
text or [Heading 2] to [Heading 6] for headlines (refer to Image 32). 
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Image 32 - Working with Aloha Editor 

6.1.1 Real Editor 
In order to get more "what you see is what you get" ("WYSIWYG") you can edit a 
page with the [Real Editor]. This means that the selected page opens in a new tab or 
window and you are able edit the page with Aloha Editor without the Gentics 
Content.Node interface surrounding the content area. 

6.1.2 Create a link 
If you want to create a link with Aloha Editor, you have to select the words which 
have to be linked and click on the link-icon (refer to Image 33). 

 
Image 33 – create a link 
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Now you can (1) enter an external URL (like http://gentics.com) or (2) choose a page 
from the Gentics Content.Node or (3) delete the link-function (refer to Image 34). 

 
Image 34 – Link menu 

If you want to choose a page from your project via Gentics Content.Node, the 
repository browser will be displayed (refer to Image 35). Now you can browse through 
the folders and choose your page. To confirm your selection you have to click on the 
selected page. 

Note: If you know the page name or a part of it from the page you want to link, you 
can enter the name into the field (1) and Gentics Content.Node will automatically 
suggest a list of one or several pages including your search term in their page name. 

 
Image 35 – Repository Browser 

After entering a URL or selecting a page from Gentics Content.Node you can edit some 
link properties by clicking on the grey arrow the top right of the content area and 
open the so called sidebar (refer to Image 36). 
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Image 36 – Open link properties 

Now an overlay dialog is displayed on the right side of the content area allowing to 
select the link target (e.g. open in self window) and enter a link title. 

 
Image 37 – Link properties 

6.1.3 Create a list 
There are two ways to creating a list with the same result. (1) Enter all list elements, 
mark the entered text and click on [numbered list] or [unnumbered list]-icon (refer to 
Image 38). 
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Image 38 – Create a list 

(2) Change the formatting before inserting the text by clicking on one of those list-
icons and enter your list elements. Both ways have the same result. 

 
Note: In some cases it is better to enter some blank lines at the end of a page before 
starting editing. If you do not need them you can delete them at any time. 

6.1.4 Create a table 
In order to create a table, click on the position where the table should be created. The 
floating menu from Aloha Editor will be displayed. Change into tab [Insert] and now 
you have to click on the table-icon (refer to Image 39 – red arrow). After clicking on 
the icon a pattern is displayed where you can decide how man cells your table should 
have. Move over a number of cells and they automatically get marked and turn blue. 
With clicking on a cell you will get a table with the numbers of marked cells. 
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Image 39 – Create a table with Aloha Editor 

After entering content into the cells you can format the text, create links, etc. In order 
to do this you have to switch from [Insert] to the [Format]-tab at the top of Aloha 
Editor. 

6.1.5 Edit a table 
At any time you can edit your table and add or delete rows or columns, make one or 
several rows or columns as table headers etc. In order to do this you have to mark a 
row or cell and choose the desired action at the automatically switched new tab at 
Aloha Editor (refer to Image 40 - red rectangle). 
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Image 40 – Edit a table with Aloha Editor 

After creating a table you can see a red and white icon at the left top corner of your 
table (refer to Image 40 - red arrow). WAI stands for “Web Accessibility Initiative” a 
taskforce which improves the accessibility of web for people with disabilities. A red 
WAI-icon means that your table has no good accessibility for people with disabilities. 
In order to achieve this you have to click on the icon and enter a caption for your 
table (refer to Image 41). Now the icon turns green and your table complies to the 
WAI-criteria. 
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Image 41 – make your table WAI ready 

6.2  Content elements 
In Gentics Content.Node, all elements of a page that an editor can process are 
displayed by "node tags". These node tags are indicated by different icons (e.g. 
symbols for images, videos, download links etc.) when you are on a page in editing 
mode (refer to red rectangle Image 42). Clicking on the respective icon opens an 
editor in which the node tag can be edited. 

The fundamental function of node tags is best explained using a simple example: If 
you wish to insert an image on a page, use a node tag "Image". In a simple image 
node tag, you define only the source of the image, i.e. you select the image file you 
wish to insert. An image can, however, also have additional properties such as e.g. 
the size in which it is to be displayed on the page, but this depends on your project’s 
implementation. 
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Image 42 – Content elements 

 

6.2.1 Insert an image 
Move the cursor to the desired position and change the tab from [Format] to [Insert]. 
Now you can choose the node tag [Image] (refer to Image 43). 

Note: It depends on your implementation and supplied node tags and group of node 
tags how the [Insert] tab looks like and in which group the node tag [Image] is 
located. 
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Image 43 – Paste an image 

Now click on [Image] and the node tag will be insert into your page (refer to Image 
44). 

 
Image 44 – Node tag icons 

In order to delete the node tag click on , for purpose of choosing an image and fill 
out your image node tag click on  and a dialog will be displayed. 
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(1) If you have already upload an image to Gentics Content.Node you can choose your 

desired image via clicking on [Repository Browser]-icon . 

 
Image 45 – Repository browser 

Now you can choose your desired image and confirm via clicking on the image name. 

If you want to upload a new image, click on [New image]. For detailed information 
about uploading an image take a look at section 5.3.1.1 Upload an image (page 24). 
If you want to edit your chosen image, click on [Imagemanipulation]. For detailed 
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information about the Gentics Content.Node Imagemanipulation take a look at 7.3 
Gentics Content.Node Imagemanipulator (page 48). 

(2) Here you can enter an alternative text for your image. At (3) and (4) you can 
choose a given size and define the image alignment. 

You confirm your settings with clicking on [OK] and you will return to the edit mode of 
your page. 

6.3  Tag list 
All node tags used in a page as well are editable are listed in the [Tag list] of a page. 
In order to see the tag list, open a page and select [Page > Tag list] via the menu 
bar. The listed tags are heavily dependent on the structuring and implementation of 
your website. 

 
Image 46 – Tag list of a page 

In the tag list of a page you see all used tags and open and edit all tags via clicking on 
the tag name. 

Note: Working inside the tag list is recommended only for users with good knowledge 
of Gentics Content.Node. 
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7. Advanced working with Gentics Content.Node 
In this section you will learn about Gentics Content.Node features for advanced 
editors. 

7.1  Create a Navigation 
As said as before the structure in Gentics Content.Node does not necessarily have to 
correspond exactly to the structure on the website, but you can easily manage the 
structure with this CMS. The created folders and pages, corresponding to the desired 
structure of your website, are the starting point for our navigation. 
Depending on your implementation you have edit some object, folder and page 
properties. 

7.1.1 Set start page 
First you have to determine a start page for your node. In order to do this, click on 
the node at the navigation section and click [Folder -> Object properties] at the menu 
bar. Now click on [Start page] and choose your desired page as starting page for your 
website. 

 
Image 47 - Object properties: Start page 

Now your website got a start page but every folder needs a start page too. To 
determine this, open the desired folder via clicking on the desired folder at the 
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navigation tree. Now select your folder start page via right-click on the desired page 
and click [Set as folder start page]. 
 

 
Image 48 – Set folder start page 

Your chosen folder start page got a red flag added to its status icon. 
 

 
Image 49 - folder stat page status icon 

Now, if someone clicks on a navigation element at the frontend, the set start page will 
be opened. 
 
Note: You can easily change the start page of your folder while setting another page 
as the folder start page. 



 

© Gentics Software GmbH 

Enterprise Portals and Content Management Systems 
www.gentics.com 

Page 43 
 

  

 

7.1.2 Sort navigation elements 
You can sort your navigation elements in every order you want. Just open the [Object 
Properties] of a folder and choose [Sorting] and enter a number. 

For Example: The first element of you navigation gets “10”, the second “20” the third 
“30” and so on. Now the CMS creates the navigation in this order but only at the 
frontend. At the CMS all folders will always be listed alphabetically at the navigation 
tree. 

Note: This sorting method has a big benefit: You can always add new elements 
without changing the others. Just create a new folder and enter e.g. “25” at the object 
property. In our example, this folder will be the third element and the previous third 
element will automatically become the fourth. 

7.1.3 Disable in navigation 
Not every folder should be displayed at frontend e.g. archives or special folders for 
images etc. and should not be part of the frontend navigation. In order to do this, 
open the object properties of such a folder and activate the object property [Disable in 
navigation]. 

If your folder has any subfolder you can apply this to them via right-click on the 
object properties and choose [Apply to subfolders] at the context menu. 

 
Image 50 - Disable in navigation: Apply to subfolders 

7.1.4 Multi-language navigation 
If you webpage has more than one language you can set translations for each 
navigation element. Just open the object properties of such a folder and enter the 
navigation elements name for every language e.g. [English name]. Depending on your 
displayed language at the frontend, the translation of every navigation element will be 
displayed now. 

7.2  Advanced working with pages 

7.2.1 Time management of a page 
Using the time management of Gentics Content.Node you can define in advance when 
and how long each individual page is to be online. In order to access the time 
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management, open the page and click in the menu bar on [Page -> Time 
management] or select it using the context menu. A dialog box will be displayed. 

 
Image 51 - Time management of a page 

The date on which the page was created for the first time appears in the field 
[Creation date]. You can overwrite this date as you wish. The creation date can also 
be relevant on your website (depending on the specific implementation of your 
project) if it is displayed automatically on your website as "News" date. In case you 
need to prepare news for a future date to be published you could edit the date in this 
dialog. 

[Date] and [Time] are additionally split into the fields [from] and [until]. The date and 
time when the page is to be published and/or is to be automatically removed from the 
server are entered here. If you enter [Date] and [Time] only in the field [from], the 
page will be published from this point and then remains online for an indefinite period. 

The assistant, which will be displayed while moving the mouse over an input field, 
shows you which format has to be used for the individual input fields. 

In the field [Weekday] you mark the days of the week on which the page is to be 
online using the corresponding checkboxes. 

Note: If you only want to specify when an existing already published page is to be 
published again, change to [Publish at] via [Page > Publish at] at the menu bar and 
fill in your desired date and time. 
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Image 52 – Publish at 

7.2.2 Take pages offline (removing pages from the server) 
If a page is removed from the server, this means that it is no longer on the web 
server and is therefore no longer accessible and only exists in the CMS. As these 
pages can be published again at any time, this is the better solution in many cases 
than deleting a page. Related pages and links are changed and automatically 
deactivated. Mark one or several pages and click [Take offline] in the action menu or 
in the right-click context menu. 

7.2.3 Versioning of contents 
All changes made by you are saved as versions, whereby the simple saving of a page 
results in an incrementing of the version number by one-tenth of a point and in the 
publication number by one point. 

Open a page and select [Page > Versions] at the menu bar or right-click on a page 
and select [Versions] and all versions of this page will be listed at the content area. 

 

 
Image 53 - Versioning 

Now you can choose and older version of your site and review or restore it or compare 
two versions. 

7.2.4 Comparing versions 
Go to the version view of a page and mark the versions to be compared by means of 
the checkboxes and then start the action "Compare versions" to switch to the preview 
mode. 
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The changes are now highlighted in red and green, with red indicating removed parts 
and green new contents. In addition you will see a 'plus' sign if you have added 
something to the content, or a 'minus' sign if you have deleted something from the 
content. If the change corresponds to a replacement, this is indicated by a yellow dot. 
Clicking on the icons will present you with a detailed view on the changes made. 

 
Image 54 – Comparison of two different versions of a page 

In order to compare the source code of the selected versions, there is a second mode 
that can be called up via the assistant area from the preview mode. 

7.2.5 Translating pages using split screen 
If you wish to translate a page to another language by yourself, you can use the 
editing mode with split screen. Right-click on the page to be translated and select 
"Translate to" and the target language at the menu. 
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Image 55 - Translate into another language 

Now you can see that the original language version is displayed in the upper part of 
the display (refer to Image 56). The lower part shows the new language version. Now 
you can edit the new language version and finally publish the new page. 
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Image 56 - Translation mode: split screen 

7.3  Gentics Content.Node Imagemanipulator 
With the Gentics Content.Node Imagemanipulator you can edit images e.g. resize or 
crop it. Just click on the name of an image at the list presentation at the Gentics 
Content.Node Imagemanipulator will be started. 

 
Image 57 - Gentics Content.Node Imagemanipulator and image properties 
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On the right side, the image properties are located (refer to Image 57 - red 
rectangle). You can change the file name, or edit the description, or close the 
properties (red arrow). 

 
Image 58 - Gentics Content.Node Imagemanipulator: functions 

With the Imagemanipulator you can resize the image using drag and drop (1), enter a 
number of pixels (2) or crop out one part of the image (3). You can even reset your 
manipulations (4) or make a duplicate of the opened image. 

7.3.1 Resizing an image 
In order to resize an image enter your desired width and/or height or drag & drop the 
icon on the bottom right corner of your image. 

If you do not activate the aspect ratio or change the picture size via drag and drop, 
your image get may be blurred. 

7.3.2 Cropping an image 
For cropping, open an image with the Gentics Content.Node Imagemanipulator, click 
on the cropping icon, and select the area to be cropped. You can move and change 
the size of the area. By clicking the green icon you confirm your configuration. 

 
Image 59 – Cropping an image 
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7.4  Search for contents in the CMS 
The list view of a folder has a quick search function which is located below the logout 
button. Enter a search term in the search field and start the search with pressing the 
enter key or clicking on the search symbol.  

This search function searches only through the active folder and their subfolders. 
Depending on the listed objects, the search term is compared with certain properties 
of the objects. Key properties here are the name and the corresponding description 
(key search word) of the object. For full-text search please use the detailed search. 

Note: Do not forget to delete your search term or clear the results through clicking on 
the delete symbol  otherwise all other objects in this folder are not being listed. 

7.4.1 Detailed search 
Via [Search] in the menu bar you also have additional search options to allow refining 
the results of your search. 

Note: All search functions always relate to the active folder, and to the type of your 
search [Pages, Images, and Files]. For example: If you want to search you complete 
web project for a particular image, you have to be on the uppermost level of the 
folder structure before you enter the search term as well as check the option “Include 
Subfolders 

 

Image 60 - Detailed search 

7.5  Show usage of objects in Gentics Content.Node 
There is a way to find out in which folders, pages, templates etc. objects like images 
or files are used. For example: It is good to know, in which pages an image is used 
before editing or deleting. In order to learn how an object is used in your projects, 
right-click on your desired object and click [Show usage] in the context menu. 
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Image 61 – Usage of an image 

7.6  Object properties 
Object properties are additional information that can be linked to a wide range of 
objects in a wide variety of forms. This additional information can then be used 
individually on the page. Depending on this information, the page set-up of the title of 
the page can be changed in the various languages. Object properties are heavily 
dependent on the structuring and implementation of your website and can therefore 
be kept very simple or made very complex. 

Change into your desired [View] and right-click on the name of an object and select 
[Object Properties] or mark the object and select [Object properties] via the action 
menu. 
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Image 62 – Object properties: e.g. folder object properties 

To edit an object property click on the name and a dialog will be displayed to the right 
of the object properties list. 

7.6.1 Folders 
Folder object properties serve, as the name indicates, to define further information for 
folders. One example of folder object properties is the creation of a multilingual 
navigation in which each folder represents a navigation point. In order to translate 
these folders, object properties can be defined which represent the navigation names 
in the various languages (e.g. English name, German name). 

7.6.2 Pages 
Just as with folder object properties, object properties can also be added to pages. 
The page object properties can vary widely. They can range from additional 
information for the formatting of the date through to information concerning the 
navigation. 

7.6.3 Images 
Image object properties are additional information that you can link to an image file. 
Apart from the properties predefined in the system (name, description), the 
administrator can also add new properties (e.g. image caption, logo, etc.). In the list 
of image object properties, you will find elements that you can fill in. This allows you 
to also assign text (e.g. an image caption), alternative text, border, etc. to an image. 
The information contained in the image object properties is saved with the image and 
is then available automatically every time the image is used in a page. In the case of 



 

© Gentics Software GmbH 

Enterprise Portals and Content Management Systems 
www.gentics.com 

Page 53 
 

  

 

information such as e.g. a copyright note, etc., it is therefore useful if this information 
is assigned directly to each image – particularly if the image is used on different 
pages. 

7.6.4 Files 
Files have certain predefined properties (e.g. file name, description), and new 
properties can be added by the administrator (e.g. copyright, etc.). In the list of file 
object properties you will find defined elements that you can fill in, i.e. not only text, 
but also links, images, etc. can be assigned to a file. The advantage of the file object 
property is that the information on the file is saved. In the case of information such as 
e.g. a file description, download note or similar text, it is far more expedient if this 
information is assigned directly to the file. 

 
 
Now you have reached the end of this manual. You got introduced to the basic 
functions of Gentics Content.Node. If you need more detailed information please visit 
the Gentics Infoportal www.gentics.com/infoportal 
 

Thank you for reading the Gentics Content.Node editor manual. 
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